6 декабря 2018 года вышел в свет WordPress 5.0.   В новой версии WordPress в качестве редактора по умолчанию используется редактор блоков Gutenberg.  Сегодня не все WordPress-темы и плагины его поддерживают.   Поэтому при редактировании и публикации контента могут возникать трудности.

СПОСОБ 1. ЖЕСТКИЙ. ОТКЛЮЧИТЬ GUTENBERG КОДОМ Вставьте следующий код в файле темы functions.php :

## Отключает Гутенберг (новый редактор блоков в WordPress).

## ver: 1.0 if( ‘disable_gutenberg’ ){ add_filter( ‘use_block_editor_for_post_type’, ‘__return_false’, 100 ); // Move the Privacy Policy help notice back under the title field. add_action( ‘admin_init’, function(){ remove_action( ‘admin_notices’, [ ‘WP_Privacy_Policy_Content’, ‘notice’ ] ); add_action( ‘edit_form_after_title’, [ ‘WP_Privacy_Policy_Content’, ‘notice’ ] ); } ); }

СПОСОБ 2. МЯГКИЙ. ВЕРНУТЬ СТАРЫЙ РЕДАКТОР WORDPRESS УСТАНОВИВ ПЛАГИН CLASSIC EDITOR

1. ПЕРЕЙДИТЕ В НАСТРОЙКУ АДМИНПАНЕЛИ ВОРДПРЕСС ПЛАГИНЫ -> ДОБАВИТЬ НОВЫЙ

Рубрики: Полезное